jQuery 2.0 bez podrške za stare verzije Internet Explorera

U iznenadnom saopštenju na jQuery blogu, tim koji razvija ovu Java Script biblioteku je odlučio da će jQuery 1.9 biti posljednje izdanje koje će podržati ranije verzije Internet Explorera. jQuery 2.0 – planiran je za puštanje u 2013 – neće više podržavati IE6, 7 i 8.

jQuery 1,9 i dalje će se razvijati i podržavati starije verzije IE. Programeri savjetuju da se u budućnosti koriste uvjetni komentari, npr.

<!–[if lt IE 9]>
<script src=”jquery-1.9.0.js”></script>
<![endif]–>

<!–[if gte IE 9]><!–>
<script src=”jquery-2.0.0.js”><</script>
<!–<![endif]–>

Ova vijest ne iznenađuje pošto  je broj korisnika IE6 i 7 pao na ispod 2 posto, dok će IE8 vjerojatno pasti ispod 10 posto do 2013.